can not connect to database



I just moved my website and databases over to a new server. The database and webserver are both working, however PHP can not connect to the database anymore via the web. However if I run "php <something.php>" (from the console command-line) it will work and generate the HTML it should from the database. Any ideas why it won't let me connect to the database via the web through PHP?

Also, when I run phpMyAdmin, I get the following error

MySQL said: Documentation
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

I am running Fedora Core 3 and mySQL. Any ideas as to why this could be happening?

Much Thanks!
well: this is probably because you did not configure phpmyadmin OR simply forgot to start the server ( DB SERVER that is) and allowed it to connect throught a socket..
Solved the problem, it had to deal with "SELinux" security feature in Fedora Core 3. So if anyone else has this problem, theres the solution! You can either disable to or allow web users to connect via a socket httpd to mysql.