Problem in installing kanboard in web server

shyam

New member
After I installed the kanboard to the Ubuntu 18 server and try to open it in browser I see this error in the browser window:

Internal Error: PHP extension required: "pdo_sqlite"

and the php is 7.4. when i try to install

"sudo apt-get install php7.4-sqlite3"

This was showing

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php7.4-sqlite3
E: Couldn't find any package by glob 'php7.4-sqlite3'
E: Couldn't find any package by regex 'php7.4-sqlite3'


I tried many way but nothing was working.

I want a way to install php7.4-sqlite3 in the server for it to work

EDIT: There are PHP versions 7.2, 7.4 and 8.1 installed.When I run:

"sudo apt-get install php-sqlite3"

I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
php-sqlite3 is already the newest version (1:7.2+60ubuntu1).
The following packages were automatically installed and are no longer required:
linux-aws-5.4-headers-5.4.0-1086 linux-aws-5.4-headers-5.4.0-1088
linux-headers-5.4.0-1088-aws linux-image-5.4.0-1088-aws
linux-modules-5.4.0-1088-aws
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.


And then I check the PHP info using:
"php -i | grep 'sqlite'"
I get nothing and the initial error still remains.

Then I check PHP info for each version and pdo_sqlite has been installed for PHP7.2:

"php7.2 -i | grep 'sqlite'"
gives this output:

/etc/php/7.2/cli/conf.d/20-pdo_sqlite.ini,
/etc/php/7.2/cli/conf.d/20-sqlite3.ini,
PDO drivers => mysql, sqlite
pdo_sqlite
sqlite3
sqlite3.extension_dir => no value => no value
 
Back
Top