PHP 7.3.x to PHP 7.4.x upgrade is not successfull

Forum for you who has PHP installation issues

Moderators: egami, macek, gesf

Post Reply
jasimample
New php-forum User
New php-forum User
Posts: 1
Joined: Thu Jan 07, 2021 8:10 pm

Thu Jan 07, 2021 9:54 pm

Previous version : 7.3.9
New version : 7.4.13
We do compile PHP from source and downloaded source from http://php.net/get/php-7.4.13.tar.bz2/from/this/mirror .
And the compilation configuration are below

./configure \
--prefix=/opt/php \
--with-apxs2=/opt/apache/bin/apxs \
--with-ldap=/opt/openldap \
--enable-soap \
--enable-sockets \
--with-pgsql=/opt/php/pgsql \
--with-pdo-pgsql=/opt/php/pgsql \
--with-mysql \
--with-pdo-mysql \
--enable-gd \
--with-jpeg \
--with-freetype \
--enable-gd-native-ttf \
--enable-pcntl \
--with-openssl \
--with-openssl-dir=/opt/libressl \
--with-curl \
--enable-mbstring \
--with-mcrypt \
--with-config-file-path=/opt/php/etc \
--with-config-file-scan-dir=/opt/php/etc/php.d \
--with-zip \
--with-xsl \
--without-libzip \
--with-pear=/opt/php/bin

Now this installation is not proper it seems .
Before 7.4.13 i see lot of utility directory present in /opt/php/lib/php/ like XML,,Mail,PEAR but after 7.4.13 i am not seeing those.

Is there any additional parameter we need to pass to install those on lib directory .
The only discrepancy i am seeing for openssl , /bin/ld: warning: libssl.so.10, needed by /usr/lib64/libssh2.so.1, may conflict with libssl.so.48

Can someone please help in this regards
Post Reply