PHP is trying to load dll disabled in php.ini

Forum for you who has PHP installation issues

Moderators: gesf, Michalio

Post Reply
otalado
New php-forum User
New php-forum User
Posts: 3
Joined: Sun Mar 20, 2022 4:33 am

I freshly installed PHP 8.1.4 VS16 x64 Thread safe on Windows 10 Pro. When I run / try to debug/run a script from VS code 1.65.2 it gives me warnings about two dlls: php_openssl.dll and php_ftp.dll.
Exact text of warnings is:

Code: Select all

PHP Warning:  
PHP Startup: Unable to load dynamic library 'php_openssl.dll' (tried: D:\AMPP\php\ext\php_openssl.dll (The specified module could not be found), D:\AMPP\php\ext\php_php_openssl.dll.dll (The specified module could not be found)) in Unknown on line 0
PHP Warning: 
 PHP Startup: Unable to load dynamic library 'php_ftp.dll' (tried: D:\AMPP\php\ext\php_ftp.dll (The specified module could not be found), 
D:\AMPP\php\ext\php_php_ftp.dll.dll (The specified module could not be found)) in Unknown on line 0
Both these 'offending' dlls are disabled (commented out) in php.ini. So the warnings area false.
Other than that, the script executes correctly in VS Code and in web browser.

I wonder if this is a problem with this PHP version or is it somehow possible that I have something wrong in the configuration?
linorrolton
New php-forum User
New php-forum User
Posts: 11
Joined: Tue Oct 19, 2021 4:47 am

Did you solve this?
User avatar
Michalio
Moderator
Moderator
Posts: 205
Joined: Sun Jul 18, 2021 1:33 pm
Location: Poland

Try to check in phpinfo() the right php.ini file, and if you using php with apache or php-fpm then restart the service.
Free coding lessons: https://php-forum.com/phpforum/viewtopic.php?t=29852
Post Reply